Outlook 2016 latest update clears POP mailbox

I’m still investigating, but it appears as if Outlook 2016 is clearing my POP mailboxes, despite the accounts having been set to keep the mail for 14 days. This always worked flawlessly, but this morning (29 feb…) Outlook started deleting all emails after reception, not only those older than 14 days.

Is it a coincidence that today, leap day, I started having this issue? (Update: yes it is. See below for latest information.)

2016-02-29_10-53-21From the mailserver logs, I can confirm from the logs it is the POP3 client (Outlook) that is sending the DELE commands. All my other devices are set to login using IMAP. If I shut down Outlook, mails are not deleted. As soon as I start it up again, deletions start again.

2016-02-29_10-57-59.jpg

Anyone else seeing this?

I am running Outlook 16.0.6568.2025 (updated this morning and now reporting it is “the latest version”).

Update 11:14

I think this must have started after updating the latest version, I am pretty sure it did not happen before the update. I started Outlook around 08:00 this morning and ran the recommended update shortly before the deletions started happening.

Update 11:28

If Josh is right (and he probably is), the fact that it is a leap day today, is a coincidence. That is unfortunate, as that means the trouble will not automatically be over tomorrow. 🙂

Since I am obviously too late to skip the update, I am investigating options to downgrade now.

Update 11:54

I can confirm that Method 2 mentioned in the KB article worked (for me) to downgrade Outlook, and that the downgraded version does not exhibit this behavior.

Will keep an eye on the article to see if it is fixed to re-enable updates.

Note that I’ve now changed the title of this blog entry to blame “latest update” instead of “leap day”.

Update 07-03

The latest version (build 2036) appears to have this issue fixed. I updated this morning and are having no problems since.

2016-03-07_11-34-26